parameters don't show up in Avenue

FFGL, OSC, GLSL. If you like abbreviations, this is the forum for you
Post Reply
User avatar
vjsjarcie
Is taking Resolume on a second date
Posts: 40
Joined: Sat Jan 24, 2009 18:48
Location: Almelo, Netherlands

parameters don't show up in Avenue

Post by vjsjarcie »

Hi there,

This is the first time i try to make something with flash in using as3.0 in flash cs4
But i keep getting errors when trying to publish my swf.
Allthough i just try to publish a slight altered sample file with the program.
I got all the code right out of the example files

When publishing, i get a 5007 error code "An ActionScript file must have at least one externally visible definition." ( amongst a trillion other beginners error codes ;-) ), but this is the most persistant one.

I think it might have to do with some of the publish settings, but i just can't figure out which.

Any help would be much appreceated since I really like the interactive part of the flash movies.

Greetz,

Sjarcie.

edwin
Team Resolume
Posts: 1153
Joined: Thu Oct 07, 2004 10:40

Re: parameters don't show up in Avenue

Post by edwin »

You should check if it is publishing as3 and flash version 9 or higher.
Could you post the code you made, so we can have a look.

User avatar
vjsjarcie
Is taking Resolume on a second date
Posts: 40
Joined: Sat Jan 24, 2009 18:48
Location: Almelo, Netherlands

Re: parameters don't show up in Avenue

Post by vjsjarcie »

Thnx for the quick response.

I have set the publish settings to as3 and flash v9.
I also published a example file with the same settings, and that came out wright.
So maybe it has to do with the code?
Attachments
square.rar
(5.65 KiB) Downloaded 606 times

Post Reply